Cloudflare outage - Ziphq.com not accessible

Incident Report for Zip

Resolved

I’m happy to share that the Cloudflare outage has now been resolved. We’ve tested our infrastructure extensively, and everything appears to be back to normal. Our engineering team will continue to monitor and please do submit a support request if you see any unexpected behavior. Thank you!
Posted Nov 18, 2025 - 08:17 PST

Monitoring

Cloudflare has identified the root cause, and the incident should now be resolved. https://www.cloudflarestatus.com

We’re closely monitoring everything on our side to make sure Zip remains stable.
Posted Nov 18, 2025 - 06:51 PST

Identified

Cloudflare is currently experiencing an outage that is also affecting Zip's infrastructure. - https://www.cloudflarestatus.com/
Our engineering team is aware of this and is working closely with Cloudflare to restore functionality as soon as possible.

Responses to customer inquiries are not affected, and customers can still reach us via email at support@ziphq.com
Posted Nov 18, 2025 - 04:14 PST
This incident affected: Zip Web App and Zip Vendor Portal.